Customer Help Center logo
Customer Help Center logo

All articles

What smartphones are compatible with invisaWear?Updated 2 months ago

  • Smartphones running Android™ version 9.0+ 
  • iPhone® models running iOS 11.0+
Was this article helpful?
Yes
No